About the Tutorial

SAP Lumira is known as a visual intelligence tool that is used to visualize data and create stories to provide graphical details of the data.

Data is entered in Lumira as dataset and you can apply filters, hierarchies, and columns to prepare documents. You can choose various charts like Bar charts, Pie charts, etc. to visualize the data effectively. This basic tutorial explains how to use SAP Lumira.

Audience

SAP Lumira is meant for Business Analysts who can alter data structures and correlations in whatever way they want. They can create data visualizations and stories from multiple data sources. SAP Lumira helps to adapt data to organizational needs to create stories with visualizations.

Prerequisites

Before you start proceeding with this tutorial, we are assuming that you are already aware of the basics of SAP HANA. If you are not exposed to SAP HANA, then we will suggest you first to go through our short tutorial on SAP HANA.

Copyright & Disclaimer

© Copyright 2018 by Tutorials Point (I) Pvt. Ltd.

All the content and graphics published in this e-book are the property of Tutorials Point (I) Pvt. Ltd. The user of this e-book is prohibited to reuse, retain, copy, distribute or republish any contents or a part of contents of this e-book in any manner without written consent of the publisher.

We strive to update the contents of our website and tutorials as timely and as precisely as possible, however, the contents may contain inaccuracies or errors. Tutorials Point (I) Pvt. Ltd. provides no guarantee regarding the accuracy, timeliness or completeness of our website or its contents including this tutorial. If you discover any errors on our website or in this tutorial, please notify us at contact@tutorialspoint.com
Table of Contents

About the Tutorial ........................................................................................................... i
Audience ......................................................................................................................... i
Prerequisites .................................................................................................................. i
Copyright & Disclaimer ................................................................................................. i
Table of Contents ........................................................................................................ ii

1. Lumira – Overview .................................................................................................... 1
   Key Terms of SAP Lumira Data Set ........................................................................ 1
   SAP Lumira – User Interface .................................................................................. 2

2. Lumira – Data Sources ............................................................................................. 4

3. Lumira – Data Acquisition ....................................................................................... 5

4. Lumira – Editing Acquired Data .............................................................................. 8

5. Lumira – Viewing Connections ............................................................................. 9

6. Lumira – Excel File as a Data Source ..................................................................... 10

7. Lumira – Working with CSV Files ......................................................................... 13

8. Lumira – Connecting SAP HANA Views ................................................................. 15

9. Lumira – Download from SAP HANA .................................................................... 18

10. Lumira – Universe as a Data Source ..................................................................... 20
    Connecting to a Universe Data Source ................................................................ 20

11. Lumira – Using Query with SQL ........................................................................ 23
    Connecting to a Query with SQL Data Source .................................................. 23
    Specifying Query with SQL connection properties ......................................... 26

12. Lumira – Working Modes ..................................................................................... 28

13. Lumira – Prepare Phase ......................................................................................... 29
    Dimension and Measure Panel .......................................................................... 29

14. Lumira – Visualize Phase ..................................................................................... 32
    Visualization Tools ............................................................................................... 33

15. Lumira – Compose Phase ..................................................................................... 35

16. Lumira – Share Phase .......................................................................................... 37
17. SAP Lumira – Creating a New Document ........................................................................ 38
   Saving Documents ......................................................................................................... 38

18. Lumira – Creating Charts .......................................................................................... 40
   Adding a chart in Chart builder .................................................................................... 40

19. Lumira – Chart Types .................................................................................................. 42

20. Lumira – Conditional Formatting ................................................................................ 44
   Creating a Conditional Formatting Rule ........................................................................ 44
   Saving Charts .................................................................................................................. 44

21. Lumira – Preparing Data in Prepare Tab ...................................................................... 46

22. Lumira – Editing Data .................................................................................................. 49
   Filtering Data in Columns and Charts ........................................................................... 49

23. Lumira – Formatting Numbers and Dates ................................................................... 51

24. Lumira – Enriching Data ............................................................................................. 53
   Creating Hierarchies ....................................................................................................... 53
   Creating a Custom Hierarchy ......................................................................................... 56

25. Lumira – Working with Datasets .................................................................................. 59
   Adding Datasets .............................................................................................................. 59
   Merging Dataset ............................................................................................................ 60
   SAP Lumira – Appending Datasets using Union Operator ............................................. 61

26. Lumira – Visualizing Data ............................................................................................ 63
   Creating Charts ............................................................................................................. 63
   Creating a Chart Directly using Chart Builder ............................................................... 65
   Plotting Measures as a Dimension in a Chart ................................................................ 66

27. Lumira – Legend Colors .............................................................................................. 69
   Adding Custom Charts .................................................................................................. 70

28. Lumira – Creating Stories ........................................................................................... 71
   Creating Stories with Charts and Data .......................................................................... 72

29. Lumira – Slideshows ..................................................................................................... 75

30. Lumira – Customizing Stories ....................................................................................... 77

31. Lumira – Sharing Charts, Stories & Datasets ............................................................... 78

32. Lumira – Publishing Datasets to HANA ....................................................................... 82
   Publishing to the SAP Lumira Cloud ............................................................................ 83
   Publishing to the SAP Lumira Server .......................................................................... 84
   Publishing Datasets to Explorer ................................................................................... 85
   Publish to SAP Stream work ...................................................................................... 86
1. Lumira – Overview

SAP Lumira is known as a visual intelligence tool to create and visualize stories on dataset. It was earlier known as Visual Intelligence tool where you could visualize data and create stories to provide graphical details of the data.

Data is entered in Lumira as data set and you can apply filters, hierarchies, calculated columns to build documents on Lumira. You can choose various charts like Bar charts, Pie charts, etc. to visualize the data effectively.

Example
You can put multiple charts on a story page to create presentation and can add images and text fields in these pages.

These stories can be published to other platforms using the publish option in the application:
- SAP Business Object BI Platform
- SAP Business Object Explorer
- SAP Lumira Server
- SAP HANA
- SAP Community Network (SCN)

Features of Lumira
The key features of Lumira are as follows:
- It allows you to predict future outcomes and forecast as per the changing market situations.
- You can create data visualizations and stories from multiple data sources.
- It helps you to adapt data to organizational needs to create stories with visualizations.
- You can share the visualizations on different platforms like SAP HANA, BO Explorer, Business Objects BI Platform, etc.

Key Terms of SAP Lumira Data Set
Data is entered in Lumira as dataset and it contains Attributes/Dimensions and Measures.
- **Measure**: Measures are defined as numerical data types. **Example**: Quantity sold, Revenue, Unit Price, Average cost, etc.
- **Attributes/Dimensions**: Data containing details about the measures is called Attributes or Dimensions in dataset. This represents the object on which analysis is done. **Example**: Customer, Product, Order, Time, Region, etc.
Hierarchies: Hierarchies are used for drilling the data to sub levels and defines a parent-child relationship. Example: Time Hierarchy, Region hierarchy.

- Custom Calculations: You can create custom calculations in Lumira data Visualization, which are not available in data set or at database level. Example: You have a “Salary” column in the data set, you can add a new calculated column with name “Bonus” and can apply a calculation on Salary to get the value of this column.

SAP Lumira – User Interface

When you login to Lumira Data visualization tool, there are four tabs at the top:

Prepare

Prepare is used to import data set in SAP Lumira. Data is cleansed and converted into appropriate measures or attributes for the reports. You can add new custom calculations here.

Visualize

The Visualize tab is used to add graphs and charts on the data that has been imported and organized in Prepare tab. You can add different attributes and measures to the Label axis.
Compose

The **Compose** tab is used to create stories and presentations, including background colors, titles, pictures, and text.

Share

The **Share** tab is used to publish your visualizations to different platforms or with different set of users in the BI Repository.
You can use different data sources with SAP Lumira to create a data set. A data source can be an Excel file, text file, clipboard, HANA Information Models, Universe created in IDT/UDT, SQL query, connected to a BEx Query or an info provider.

Once you open SAP Lumira, go to **File -> New Data set**

You can select from various Data sources to create a new data set.

- **Microsoft Excel**: Load an Excel Worksheet as a dataset
- **Text**: Load a text file (*.csv, *.txt, *.log, *.pm, *.tsv) as a dataset
- **Copy from Clipboard**: Copy from Clipboard
- **Connect to SAP HANA**: Connect to data in an SAP HANA View
- **Download from SAP HANA**: Download data from an SAP HANA view as a dataset
- **Universe**: Connect to a Universe and download a dataset
- **Query with SQL**: Run freehand SQL on a database to download a dataset
- **Connect to SAP Business Warehouse**: Connect to a BEx Query or an InfoProvider
3. Lumira – Data Acquisition

The key steps in **Data acquisition** are as follows:

- For data acquisition in SAP Lumira, create a new document that will contain the data and visualization of acquired data.
- Next is to connect to a data source, which contains data for visualization.
- Acquire the data to create a data set.
- Data acquisition can be done from multiple compatible data sources to use in a single visualization or data analysis.
- Once data is acquired, it comes under the **Prepare** tab.

- Select a Data Source. Enter the system details from where the data is to be acquired and click **Next**.

---

### File Edit View Data Help

- Open Ctrl+O
- New Ctrl+N
  - *Create a new dataset*

---

**Select a Source:**

- **Microsoft Excel**
  - Load an Excel Worksheet as a dataset
- **Text**
- **Copy from Clipboard**
- **Connect to Clipboard**

**Connect to SAP HANA**

- Connect to data in an SAP HANA View
- **Download from SAP HANA**
  - Download data from an SAP HANA View as a dataset
- **Universe**
  - Connect to a Universe and download a dataset
- **Query with SQL**
  - Run freehand SQL on a database to download a dataset
- **Connect to SAP Business Warehouse**
  - Connect to a BEx Query or an InfoProvider

---

**Recently Used: Connect to SAP HANA**

- ANV_SALES
  - best_SY9_BIC/prashanthi
- SALE_VIEW_ANA
  - best_SY9_BIC/prashanthi
- TEST_ANA
  - best_SY9_BIC/prashanthi
- DEMP_ANA
  - best_SY9_BIC/prashanthi
- SHOWY_ANA
  - best_SY9_BIC/prashanthi
- TEST_CAL
  - best_SY9_BIC/prashanthi

---

**Previous**  **Next**
Select a Data source like SAP HANA View and click **Next**.
- Select **Dimensions and Measures** and click **Create**.

![SAP Lumira interface](image)

- No filter applied currently on the dataset

![Dataset view](image)
Let us learn how to edit the acquired Data. Follow the steps given below.

1. To edit data in **SAP Lumira**, go to the **Data** tab and click **Edit Data Source** from the menu.

2. It will take you to Edit Data Source window, where you can again select **Measures and Dimension**.

3. You can check or uncheck any of the attributes and measures to add to data set and click the **OK** button.
In SAP Lumira, you can check all the connections for an existing application and document associated with each connection and you can change the data source for an existing connection.

To view existing connections, close all the data set.

1. Click **New** and close the **Add new data set** window. In the left pane, it will show you the **Connections** option.

2. A new window will open with a list of all the existing connections and associated documents. Click a connection and you can change the target data source.
6. Lumira – Excel File as a Data Source

You can use an Excel file to create data set in SAP Lumira.

Follow the steps given below.

1. Go to File -> New (Create a data set).

2. Select a Source: Load an Excel worksheet as a dataset and click the Next icon at the bottom.

3. Browse the path of .xls file. You have an option to choose the first row as column names. You can hide a particular column from .xls by selecting the Select All option.
4. You can click the **Advance** option to select a custom range. You can also include hidden rows and columns. Once correct options are selected, click the **create** button at the bottom.

5. All the data with integer values appear under **Measures** and all the columns appear under **Dimensions**. This data will come under the **Prepare** tab.
6. Go to the **Visualize** tab at the top to create the visualization on top of the data set.
You can use a Text file as a data set like .csv file, .txt file, .log file, .prn file, .tsv file. The following steps explain how to use a text file as a data set.

1. Go to File -> New -> Add New Dataset -> Next.

2. Select the path of csv file, for example an Excel file. You can set the first row as column names. Select the separator as comma, tab, etc.

The Advance option can be used to select the Number and Date format. Click the Create button to enter the data in the Prepare tab.
<table>
<thead>
<tr>
<th>Emp ID</th>
<th>EMP NAME</th>
<th>SALARY</th>
</tr>
</thead>
<tbody>
<tr>
<td>123</td>
<td>ABC</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Jason</td>
<td>5000</td>
</tr>
<tr>
<td>4</td>
<td>Jim</td>
<td>2400</td>
</tr>
<tr>
<td>5</td>
<td>Sally</td>
<td>4500</td>
</tr>
<tr>
<td>3</td>
<td>John</td>
<td>3456</td>
</tr>
<tr>
<td>1</td>
<td>Anna</td>
<td>2500</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
End of ebook preview
If you liked what you saw...
Buy it from our store @ https://store.tutorialspoint.com